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When creating a site for the first time in Dreamweaver, there 

are two very important steps you need to take: defining the 

site, and creating the index.html (or in some cases, index.

htm) file.

DEFINING A SITE First, create a folder on your hard drive where you are going 

to save all your files for this class. This will be referred to as 

the root folder. You can call it anything you want. This is 

where everything you create for your site should be stored. 

Create subfolders as needed to stay organized! These steps 

are for CS4. Instructions for CS5 follow.

1.	 Launch Dreamweaver.

2.	 Go to Site > Manage Sites.

3.	 Create a new site (if  you don’t have one already de-

fined).

4.	 Click the Advanced tab at the top of  the site definition 

window.

The next series of  dialog boxes require you to type in the 

information that allows Dreamweaver to display your site 

files, connect to a server, and update links (very important!!) 

when you make changes.

The following images illustrate what you should type in 

each area—panels not included here are ones you can 

safely ignore for now.

LOCAL INFO

5.	 Site name: you can call this anything you want; it’s the 

name Dreamweaver will display in the Files pane.

6.	 Local root folder: click the folder icon to create or 

browse to, and select, the folder in which you’re going 

to save all your site files (assets). This should be located 

on your hard drive or removable media.

7.	 Default images folder: if  you want to keep all the im-

ages you create in a single folder, you can specify that 

here. I recommend against that as it can get confusing, 

especially when developing anything interactive (i.e. 

buttons, or rollovers) in Fireworks.

8.	 HTTP address: type in the absolute URL for your site 

here. 
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REMOTE INFO

You will have to have a domain and web hosting before you 

can set up the remote information.

You will need your domain name, user name and password 

information handy. 

9.	 Click on the Remote Info category

10.	 ACCESS: select FTP (check with your service provider to 

make sure of  the access type if  this doesn’t work. If  you 

are using mysite at SU, the access type is WebDAV).

11.	 FTP host: this is the domain name you purchased (i.e. 

tatoland.com). Note that you may not need the http:// 

before the domain. If  you are using the SU server, your 

URL is https://username.mysite.syr.edu/admin  (note 

the S after http!)

12.	 LOGIN: your username

13.	 Password: your password; either the one you used when 

you set up your domain hosting, or your SU netID.

14.	 UNCHECK maintain synchronization information for 

now. 

15.	 Click the “test” button. You should get a message that 

Dreamweaver was able to connect to your server suc-

cessfully. If  you don’t, double-check all the information, 

and make sure you have an internet connection.

CLOAKING

16.	 Click on the Cloaking category, then check the “enable 

cloaking” checkbox. This will prevent files that don’t 

belong on the server from being transferred by mistake. 

You can add file extensions here for any document 

types that do not belong on the remote server, including 

PSD, AI, DOC or DOCX, and so on.

17.	 Click OK, then click DONE.

NOTE: If  you work on different computers, you will need 

to define your site on each one as it’s the local copy of  

Dreamweaver that tracks the root folder.

The important panels to fill out are Local Info, Remote Info, and 
Cloaking. More on the other panels to come.
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SETTING UP A SITE IN CS5

1.	 Use Site > New Site to open the site definition panel.

2.	 Give your site a working title; this can be anything you 

want.

3.	 Click the folder icon and browse for the root folder you 

created on your hard drive.

4.	 Select the Servers option at the left. 

5.	 Click the + sign at the bottom, and then type your 

server name in the first field. 

6.	 Choose FTP to connect unless your service provider has 

indicated a different protocol. If  you are using the SU 

server, select WebDAV instead.

7.	 Add the FTP address to your site. This may or may not 

be the same as the Server Name. If  you are using the 

SU server, the FTP address will be https://username.

mysite.syr.edu/admin. (Replace “username” with your 

username.) Note the S after http, and the “admin” after 

the server name.

8.	 Type in your netID and password.

9.	 Click the Test button to make sure you can connect to 

your remote host.

The Root Directory is where you would add the folder name 

on your remote site where your files will go. Check with 

your service provider if  you’re not sure whether that’s 

required or not.

10.	 Type in the URL for your site. If  you are using the SU 

server, the URL will be http://username.mysite.syr.edu. 

Note there is no S after http, and no “admin” after the 

server name.

11.	 Click the triangle next to Advanced Settings and then 

choose the Cloaking category.

12.	 Check the Enable Cloaking option. Add any other ex-

tensions that you want to keep from transferring to the 

remote site, like AI, INDD, DOC or DOCX and so on.

13.	 Click Save, and then Done.
2. Give your site a name so Dreamweaver can track it.

3. Use the folder icon to locate and select  
the local root folder you created.

5. Type in the server name.

6. Select the file transfer protocol type (FTP or WebDAV).

7. Add the FTP address for your site. If  you aren’t sure  
what it is, check with your service provider.

8. Fill in the Username and Password information. 
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The next step is to create the index.html file—the docu-

ment that a web browser will display automatically when 

someone types in your URL. It is the “home” page, or “first” 

page of  any site, and it must be named index.html. If  you 

call it anything else, it will not be the first page in your site. 

All sites have an index.html file. This index.html file should 

be saved in your root folder, but not inside any subfolders. 

The file name (index.html) has nothing to do with the title 

of  your web page. Do NOT use the file name as the title for 

the page. They are two different things.

1.	 Create a new HTML file using File > New.

2.	 In the New Document dialog box, select Blank Page. 

Choose HTML for Page Type, and <none> for Layout.  

At the bottom right of  this panel, make sure DocType is 

set to XHTML 1.0 Transitional. This is the standard for 

current web sites.

3.	 Click Create.

Once you are in the Dreamweaver interface, there is an aw-

ful lot to look at! Before getting too distracted, though;

4.	 Click the Split View option at the top left of  the docu-

ment window.

In the center at the top of  the document, you will see a Title 

field. 

Create a new document (Command N). Select Blank Page, then 
HTML for Page Type and <none> for layout. 

Click the Split option so you can see the code as well as the design 
area. If  you want it side by side, as above, use View > Split Vertically. 

Save the file in your root folder—don’t place it in a subfolder. Name 
it index (no caps). Dreamweaver will automatically add the HTML 
extension for you. 

Type a descriptive page title in the Title field at the top of  the docu-
ment window.

CREATING YOUR FIRST PAGE 5.	 Enter a very descriptive name for your HTML page. It 

can have spaces and capital letters, punctuation, and 

so on. This is the text that a browser will display at the 

top of  the page, and what people will see when they 

bookmark your site.

6.	 Then, type something in the content area (design 

pane). It doesn’t matter what you type at this point, 

since this page will change, once you get into actually 

designing and composing things.

7.	 Save the file using File > Save (Command S) and name 

it index. Do not use any capital letters. Do not try to get 

creative and call it “home” or “myfirstpage.” It must be 

called index. Dreamweaver will add the HTML exten-

sion automatically.

8.	 Navigate to the folder you are using as the root folder 

for your site, and press Save. Do not put this file in a 

subfolder. Leave it “loose” in the root folder.



UPLOADING THE INDEX PAGE

Click the plug icon next to the site name at the top left of  the 

Files pane to connect to your remote server.

You’ll then be connected to your server, and may see a list of  

folders and/or files, if  there are any, or just a root folder icon. 

This is called the remote site, or remote server.

This is the folder where all the required files will go once 

your site is fully developed. 

To move files, simply click and drag them from the right 

pane to the left pane.

10.	 Click and drag the “index.html” file over to the server. 

Drag it on top of  the root folder, and make sure you 

see a green circle with a + in it before letting go of  the 

mouse button. Dreamweaver will ask you if  you want 

to move any dependent files—those images, anima-

tions, and so on, that may be part of  your index page. 

Click “yes.”

11.	 Then open a browser and type in your URL. Nice!

What’s your URL? It depends on where your remote site is 

located. If  you are using the SU server, then your URL is:

http://yournetid.mysite.syr.edu/

If  you have purchased your own domain, then the URL will 

be:

http://yourdomainname.com/

  

Connect to your remote server by clicking on the plug icon in the 
Files pane.

Drag the index.html file on top of  the remote folder. When Dream-
weaver asks if  you want to include dependent files, click yes.



At the beginning of  this document, there was a basic intro-

duction to defining a site in Dreamweaver. That’s because 

Dreamweaver semi-freaks if  you try to create a web page 

that isn’t part of  a site. Once you’ve defined a site, with a 

local root folder and an index page, you can work forever 

without worrying about a thing. As long as you don’t 

change computers (in which case you’d need to re-define 

the site) or move stuff  around on your hard drive.

Putting a web page together in Dreamweaver is a lot like 

putting a print piece together in InDesign. Instead of  actu-

ally placing real Photoshop files (saved as PSD, TIFF, or EPS) 

on a page, InDesign remembers where the image is located 

and displays a placeholder image instead (which is why 

they usually look crappy). When you print the file, InDesign 

grabs the “real” image file and prints that instead (which is 

why it looks so good). If  you move the image file, InDesign 

looses track of  it and lets you know there are missing links.

As you work on a web page, Dreamweaver is “remember-

ing” where all the GIFs, JPGs, PNGs, animations, and 

Fireworks htm files are located so that the paths it creates 

are accurate. These pieces (called assets) are not embedded 

in the page. Instead, the HTML code tells a browser where to 

go to look for the image or animation. Thus, the HTML code 

to display an image is actually the path from the file to the 

image:

<img src=”images/mypicture.jpg”/>

Because Dreamweaver is “remembering” and writing the 

code that finds and displays things, it’s critical that those 

things are where Dreamweaver thinks they are. Just as if  

you moved a TIFF file and InDesign can’t find it, if  you move 

a JPG, Dreamweaver can’t find it.

So if  at some point you decide to rearrange the contents 

of  the root folder on your hard drive, Dreamweaver looses 

track of  anything you moved, and you’ll get nasty gray 

broken image icons everywhere. The only thing to do at that 

point is re-insert all of  it again, in every file where it was 

used. NOT fun.

File management, or site organization, is a really important 

piece to a site functioning properly, and to avoiding tears 

and hair loss. It is perfectly OK to drag a file from one place 

on your hard drive into the root folder. It is NOT OK to move 

something from one place in the root folder to another loca-

tion in the root folder. It’s also NOT OK to delete anything 

from the root folder. The only exception to this is if  you are 

absolutely sure you are not going to need that file, and have 

not used it in any of  the site pages.

If  you decide you need to move or rename a file, do it from 

the Files panel in Dreamweaver, NOT from the desktop 

window of  your site folder or disk.

Rearranging file using the Files panel maintains all the links 

in all the documentsv. Remember, in this case, the word 

“link” is used to refer to the fact that no images or multime-

dia is actually embedded in an HTML file, but rather con-

nected via a path from the HTML file to the media file. It will 

also update URL links between HTML files (those attached 

to text or images used to navigate a site).

SITE MANAGEMENT

If  you start rearranging where stuff  is in your root folder on your 
hard drive, Dreamweaver looses track of  where things are and 
you’ll have to start all over again. If  you need to reorganize things, 
do it using the Files panel in Dreamweaver!

If  you need to reorganize 
your root folder, create new 
folders (and files) using the 
Files panel in Dreamweaver 
(control-click to access 
those options) and move 
things by dragging them 
within the Files panel, not 
on the hard drive. 

Do not move files in the 
root folder on your hard 
drive; use the Files panel 
(above) to rearrange 
things.



Reorganize the documents and images in your site from the 

Files pane like this:

Control click on the site folder—the one at the top of  the 

files list. Select New Folder from the pop-up menu.

Click on the new folder icon in the list to name it.

Move any files and/or images by clicking and dragging 

them from the files list into the folder: you can Shift-click or 

Command-click to select a range of  documents at once.

Dreamweaver should then ask you if  you want to update 

any links associated with those files. Click Update!

One thing you should always do when defining a site (and 

can update by editing a site) is to set up Cloaking. Cloak-

ing prevents any inappropriate files (like PSD, or FLA) from 

being uploaded to the web. Since a Photoshop image can’t 

be seen in a browser, there’s no point in clogging up server 

space by uploading it. If  a file type has been cloaked, it will 

never be transferred to the remote server, even if  you move 

an entire folder of  files with some of  that type in it.

Whenever you move something from one place  
to another in the Files panel, Dreamweaver will attempt  
to keep the links updated accordingly.

Turn Cloaking on using Sites > Manage Sites and selecting the 
Cloaking category. Add any extension you may have in your root 
folder that does not belong on the remote server.

Anything that has been cloaked is represented by a slash through it 
in the Files panel (below).

Control-click on the root folder in the Files panel to create new fold-
ers when reorganizing things. You can create new HTML files this 
way as well.



UPLOADING YOUR SITE

Finally, get all your pages online!

Before you go further, if  you haven’t turned on the Cloak-

ing option, open Manage Sites from the Site menu. Click on 

“cloaking” to access that panel. 

Check the “enable cloaking” box, and the “cloak files ending 

with” box.

In the field below, type:

.fla .psd .eps .tif  .tiff  .doc .indd 

so none of  these “originals” will be uploaded to the server. 

You don’t need them for your site to work, and they’ll just 

take up precious space on the server.

Click OK, and then Done to exit the Site Management dialog 

box.

Now, to upload your site files: 

Make sure that your site is the current site named in the 

Files pane, and click on the connect to server icon.

You should see a folder at the top left—depending on how 

your server is set up, it may have a name, or merely a slash 

( / ). You may also see some other files—perhaps something 

you uploaded previously.

If  there are old files in your remote folder, and they are 

they’re something you don’t need, select them in the remote 

site list and press the delete key. If  you want to back them 

up, just in case, select them and press the down arrow in the 

Files panel (“get files”). They will be moved to the current 

root folder, so you may end up with a big mess. Be careful!

Click on the index.html file from the local site and drag it 

on top of  the root folder in the remote site—make sure you 

position it exactly over the folder, and see a green circle with 

a + symbol in it.

Dreamweaver will ask if  you want to include all dependent 

files. I usually click yes. Dreamweaver then uses the transfer 

protocol you chose when defining the site to move the index.

html file to the server, and also moves any folders and files 

used on that page. That means, if  there’s a nav bar from 

Fireworks on the page, Dreamweaver moves the folder with 

all the slices associated with it to the server as well.

If  you select No, you’ll have to move folders and other as-

sociated files by clicking and dragging them to the server 

manually. This isn’t a bad thing to do, either. But you do 

need to know what you’re doing or things can get pretty 

messy. It’s a matter of  preference.

You can also move files/folders by selecting them and using 

the Put arrow (the blue one).

Once you’ve moved the index.html file over, open a web 

browser and type in your URL. See if  it works! 

If  there are missing image icons and broken links, fix them 

in Dreamweaver, and upload the edited files again.

I’ve found the biggest issue is that all the parts of  a nav bar 

don’t always show. I just upload the folder where all the 

slices for the nav bar are located, hit the refresh file list but-

ton, and try again.

Don’t despair if  you find you still have some work to do to 

make your site fully functional. It’s just the way of  the web 

world and even the most professional and experienced web-

masters have been known to scratch their heads, wondering 

why things don’t work.

It’s a good idea to leave yourself  at least 2 weeks for upload-

ing, correcting, and re-uploading files.

When it’s all together and functioning perfectly, pat yourself  

on the back!

In the Files panel, click on the plug icon to connect to the remote 
server

Drag the files and folders you need from the local side to the remote 
side of  the Files panel. Make sure you drop them on top of  the root 
folder on the remote side; make sure you see the green + sign before 
letting go.

PUT files from local to remote 
site.

GET files from remote site.

Select the file(s) you want to move, then use either the GET or PUT 
arrow to move them back and forth.


